3. Installation

3.1. Requirements

Optional:

3.2. Installation

3.2.1. Debian or Ubuntu

There is a deb package (beamparticle-<ver>_x86_64.deb), which directly installs on base Debian 9 or Ubuntu system (16.04+).

3.3. Building from source

The following packages must be installed otherwise the NIF (c code) for eleveldb will fail to build. Note that libssl-dev is required by snappy (a requirement of eleveldb).

sudo apt-get install build-essential sudo apt-get install libssl-dev

3.3.1. Code

The development uses git version control and the code can be cloned as follows:

3.3.2. Building the deb package

Building the package is wrapped in a make target.

make deb-package